Help us improve EA Help! Take Survey No, Thanks
MENU MENU

This article explains the system requirements to play Pogo games on Windows and Mac and teaches you about the Compatibility Scan tool on Pogo.com.

Requirements and Compatibility Scan Windows requirements Mac requirements HTML 5 game requirements Unsupported browsers

System requirements for Pogo and Compatibility Scan Tool

Browser/Operating System Not Supported! error

If you need help determining whether you can play Pogo games using your current (operating system) OS and browser, you can use the Pogo Compatibility Scan tool. This tool automatically scans your computer and browser to alert you if you might have trouble using Pogo.

At the bottom of the screen, you can find your computer’s System Information that can help identify if you’re using the correct software to play Pogo games.

Example of a scan

Screenshot of Compatibility Scan on Pogo.com

Pogo requirements for Windows

Here is a listing of Operating Systems and Browsers that are compatible to play Pogo games. If you’re using an Operating System or Browser not found in this list, you may need to switch to one of these.

Windows 10

  • Firefox
  • Edge - Does not support Java games
  • Chrome - Does not support Java games

Pogo requirements for Mac

Mac (latest version)

You need these specs to play HTML 5 games

Windows 10

  • 8GB of system RAM
  • Chrome, Edge, or Firefox browser

macOS High Sierra (10.13.6) or newer

  • 8GB of system RAM

Unsupported browsers for HTML 5

  • AOL
  • Internet Explorer 11
  • Opera
  • Old versions of Internet Explorer and Mozilla Firefox
  • Pale Moon
  • Safari for Windows (last supported version was 5.1.7)
  • SeaMonkey
Contact Us

Was this article helpful?

0% of 0 players found this article helpful.

Related content

Was this article helpful?

0% of 0 players found this article helpful.

X