Aidez-nous à améliorer l'Assistance EA ! Participer à l'enquête Non merci
MENU MENU

Cet article n'est pas disponible en Français. Vous pouvez le consulter en anglais ici, ou nous contacter pour parler à un conseiller dans une autre langue.

Ce contenu fait partie de nos archives et n'est compatible qu'avec une précédente version d'un jeu ou service.

Browsers Battlelog will support and not support.

Battlelog requires a browser able to run its plugins properly in order to to play BF3. Below are our recommendations. Please note this is not an exhaustive list.

Recommended

Will run, may cause issues

Will not run

  • Internet Explorer 8 and earlier
  • Safari

Was this article helpful?

0% of 0 players found this article helpful.

Contenu EA en rapport

Was this article helpful?

0% of 0 players found this article helpful.

X